Jump to content

Photo

Battlefield Admin Control Panel for AdKats [BFACP]

BF3 BF4 BFH AdKats

  • Please log in to reply
241 replies to this topic

#1
Prophet731

Prophet731

    Administrator

  • Administrators
  • 169 posts
  • Discord Username:Prophet#7405

Donator

Running on PHP Version 7
 
This does not work with any version of the BFACP do not try to run this application on that version. Use the latest stable PHP 5.6.

 

Readme for version 2.0.3. Download
 
Readme for version 2.1-dev. Download

Further instructions for version 2.1-dev. Make sure to run the setup.sql script if you are not installing through the command line. Previous versions should not be in the database if you have to manually run the setup.sql script as it will throw an error when it tries to create the tables.

Topic placeholder for version 3.0. I'll update this post when version 3 is released. For now support can be placed here instead of spamming the AdKats thread.

 

Version 3.0 Development Repo


  • icecold and Tan0c like this
The developer of the Battlefield Admin Control Panel (BFACP)
 
Do not contact me via PM on the forums for help with procon. Please make a topic for it. Only PM's I will accept will revolve around any website issues. 
 
For BFACP support please post in the BFACP topic linked above.

#2
Kracklin_Bacon

Kracklin_Bacon

    Advanced Member

  • Active Members
  • PipPipPip
  • 52 posts
  • Discord Username:Kracklin_Bacon

Donator

Quick question:

 

Currently in AdKats, I have the players being reported go to Discord. We are getting them in the inbox, but no sound alert.

 

Thanks


Edited by Kracklin_Bacon, 03 August 2019 - 10:19 AM.


#3
Prophet731

Prophet731

    Administrator

  • Administrators
  • 169 posts
  • Discord Username:Prophet#7405

Donator

It should play sound but I don't remember on that version. I'd have to look.

Sent from my ONEPLUS A5010 using Tapatalk
The developer of the Battlefield Admin Control Panel (BFACP)
 
Do not contact me via PM on the forums for help with procon. Please make a topic for it. Only PM's I will accept will revolve around any website issues. 
 
For BFACP support please post in the BFACP topic linked above.

#4
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Merge Post

Edited by Prophet731, 07 August 2019 - 06:44 AM.

* Restored post. It could be that the author is no longer active.

#5
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Checka_Wiemi*:

We're using AdminCP 2.0.1 (newer version until 2.0.3 didn't work yet and I had no time to try 2.1).
I got an issue on my scoreboard: I can't see my playerslist.
Chat and everything else is there but no playerlist.
This is since a few days and I couldn't fix it.
In my errolog this message appears:
"production.ERROR: exception 'ErrorException' with message 'Undefined offset: 10' in BFAdminBF3/app/bfacp/Libraries/BF3Conn.php:2709"
I had a look into this file and line and there is:
"$nRows = $res[10];"
I can remember that there was kinda bug after the last BF3 server update but I can't remember if it was this line or another.
Maybe someone knows a solution.
* Restored post. It could be that the author is no longer active.

#6
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Prophet731*:

We're using AdminCP 2.0.1 (newer version until 2.0.3 didn't work yet and I had no time to try 2.1).
I got an issue on my scoreboard: I can't see my playerslist.
Chat and everything else is there but no playerlist.
This is since a few days and I couldn't fix it.
In my errolog this message appears:
"production.ERROR: exception 'ErrorException' with message 'Undefined offset: 10' in BFAdminBF3/app/bfacp/Libraries/BF3Conn.php:2709"
I had a look into this file and line and there is:
"$nRows = $res[10];"
I can remember that there was kinda bug after the last BF3 server update but I can't remember if it was this line or another.
Maybe someone knows a solution.

Yes that has been fixed. Just save this file and upload it back to the folder and it should fix the problem.

https://github.com/A....es/BF3Conn.php
* Restored post. It could be that the author is no longer active.

#7
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Checka_Wiemi*:

Yeah I already solved this problem by changing in line 2709 the "10" into a "9" and everything was fine.
But I wonder why this happened now?
Thanks for the help Prophet :-)
* Restored post. It could be that the author is no longer active.

#8
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Checka_Wiemi*:

I just tried to install the version 2.1 on a clean system (didn't want to update my current adminCP).
So I've uploaded all files and edited the .env.php (see picture here: ).
Now I've tried to open the subdomain for the adminCP and I get the following error:

Does anyone got a clue?
* Restored post. It could be that the author is no longer active.

#9
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Prophet731*:

I just tried to install the version 2.1 on a clean system (didn't want to update my current adminCP).
So I've uploaded all files and edited the .env.php (see picture here: ).
Now I've tried to open the subdomain for the adminCP and I get the following error:

Does anyone got a clue?

What it looks likes is that the APP_KEY is not being registered on boot which would cause that error. Make sure the file on the server has those changes. Also running this version does make some database changes to the bfacp tables if you were on the latest non-dev version. So make sure you have a backup of the tables just in case.

Sent from my ONEPLUS A3000 using Tapatalk
* Restored post. It could be that the author is no longer active.

#10
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Checka_Wiemi*:

What it looks likes is that the APP_KEY is not being registered on boot which would cause that error. Make sure the file on the server has those changes. Also running this version does make some database changes to the bfacp tables if you were on the latest non-dev version. So make sure you have a backup of the tables just in case.

Yeah I also thought about that issue with the key but I've take the key from another db (where version 2.0.1 is running) and this key is also 32 characters long and I just changed some letters in the new one (didn't change the length).
I also took a new database to test this version.
Didn't want to fuck up my old database ;-)

But as I already said: the key is okay in my oppinion but I don't know why he won't start the side?
I've also tried several 16, 24 and 32 characters keys but none worked.
* Restored post. It could be that the author is no longer active.

#11
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by keb2*:

Hi.In my Console, Procon shows this error:17:25:49 90] [AdKats] WARNING: Unable to find source weight for command 18|40,WARNING: Unable to find source weight for command 18|61
Which version is the latest:2.0.3 or 2.1?
* Restored post. It could be that the author is no longer active.

#12
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Checka_Wiemi*:

Hi.In my Console, Procon shows this error:17:25:49 90] [AdKats] WARNING: Unable to find source weight for command 18|40,WARNING: Unable to find source weight for command 18|61
Which version is the latest:2.0.3 or 2.1?

Wrong thread.
Ask it in this one: myrcon.net/.../advanced-in-game-admin-and-ban-enforcer-adkats
* Restored post. It could be that the author is no longer active.

#13
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by keb2*:

Wrong thread.
Ask it in this one: myrcon.net/.../advanced-in-game-admin-and-ban-enforcer-adkats

I wrote the message in the correct subject.This error comes from BFACP
* Restored post. It could be that the author is no longer active.

#14
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Hodor*:

BFADMINCP it is web, AdKats it is plugin. AdKats errors this thread myrcon.net/.../advanced-in-game-admin-and-ban-enforcer-adkats
* Restored post. It could be that the author is no longer active.

#15
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Prophet731*:

Hi.In my Console, Procon shows this error:17:25:49 90] [AdKats] WARNING: Unable to find source weight for command 18|40,WARNING: Unable to find source weight for command 18|61
Which version is the latest:2.0.3 or 2.1?

The latest one that I did was 2.1 but that's the development version. If your comfortable with the command line it's easy to set up.

Sent from my ONEPLUS A3000 using Tapatalk
* Restored post. It could be that the author is no longer active.

#16
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by keb2*:

The latest one that I did was 2.1 but that's the development version. If your comfortable with the command line it's easy to set up.

Sent from my ONEPLUS A3000 using Tapatalk

Ok.
How do I fix these errors:WARNING: Unable to find source weight for command 18|40,WARNING: Unable to find source weight for command 18|61?
Version 3 will run on PHP7?
* Restored post. It could be that the author is no longer active.

#17
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Prophet731*:

Ok.
How do I fix these errors:WARNING: Unable to find source weight for command 18|40,WARNING: Unable to find source weight for command 18|61?
Version 3 will run on PHP7?

Here's the post I made that resolves that problem.

myrcon.net/...advanced-in-game-admin-and-ban-enforcer-adkats#entry41481

Version 3 will run on PHP7 but it won't be able to run on older versions of php.
* Restored post. It could be that the author is no longer active.

#18
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by keb2*:

Here's the post I made that resolves that problem.

myrcon.net/...advanced-in-game-admin-and-ban-enforcer-adkats#entry41481

Version 3 will run on PHP7 but it won't be able to run on older versions of php.

Thanks:smile:
* Restored post. It could be that the author is no longer active.

#19
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Checka_Wiemi*:

Okay, now AdminCP 2.1 is running and connected to the database (had to run 2.0.3 over the db and then 2.1 started working).
But now I got the problem that I can't login.
The decfault login with admin and password isn't working. It says: "Please type in an email address" and if I'm registering an account and want to login with my email address it says:
"Database Error!

Sorry, something went wrong with the database."

So I'm not sure what happened. If you wanna have access to the database it shouldn't be a problem, so I can send you login?
* Restored post. It could be that the author is no longer active.

#20
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Prophet731*:

Okay, now AdminCP 2.1 is running and connected to the database (had to run 2.0.3 over the db and then 2.1 started working).
But now I got the problem that I can't login.
The decfault login with admin and password isn't working. It says: "Please type in an email address" and if I'm registering an account and want to login with my email address it says:
"Database Error!

Sorry, something went wrong with the database."

So I'm not sure what happened. If you wanna have access to the database it shouldn't be a problem, so I can send you login?

How are you installing this by the way? Through the command line or through the download link above? If you have command line access to your web server along with git and composer installed on it following the instructions at the bottom of the readme should have set everything up for you.

https://github.com/A....ng-dev-version
* Restored post. It could be that the author is no longer active.

#21
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Checka_Wiemi*:

How are you installing this by the way? Through the command line or through the download link above? If you have command line access to your web server along with git and composer installed on it following the instructions at the bottom of the readme should have set everything up for you.

https://github.com/A....ng-dev-version

I just got webspace and upload these files. So I can't use the command line :-(
* Restored post. It could be that the author is no longer active.

#22
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by )RAG()N*:

Version 3 will run on PHP7 but it won't be able to run on older versions of php.

have you got any ETA on for the new version Prophet ?
* Restored post. It could be that the author is no longer active.

#23
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by keb2*:

Tell me why the list of Battlefield 3 players is not displayed&
2017-12-02_102804.png
In Battlefield 4 with this all right
2017-12-02_213215.png
* Restored post. It could be that the author is no longer active.

#24
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Checka_Wiemi*:

Tell me why the list of Battlefield 3 players is not displayed&
2017-12-02_102804.png
In Battlefield 4 with this all right

Did you write down your server password in Site Management -> Servers and then click onto your server and fill in your RCON Password.
* Restored post. It could be that the author is no longer active.

#25
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by keb2*:

Did you write down your server password in Site Management -> Servers and then click onto your server and fill in your RCON Password.

Yes, I did it all before.All ports on the computer are open.The database is used the same as for Battlefield 4.
* Restored post. It could be that the author is no longer active.

#26
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Prophet731*:

I just got webspace and upload these files. So I can't use the command line :-(

Ok well in the download folder there should be a file located in the scripts folder called "setup.sql". Run that on the database where adkats is installed and it should work once it's done. Make sure no other bfacp? tables exist as it will throw an error.

have you got any ETA on for the new version Prophet ?

I do not have an ETA for version 3. I would like to have it done maybe by february. Not a forsure thing though.

Tell me why the list of Battlefield 3 players is not displayed&
2017-12-02_102804.png
In Battlefield 4 with this all right
2017-12-02_213215.png

See this post.

myrcon.net/...battlefield-admin-control-panel-for-adkats#entry52394
* Restored post. It could be that the author is no longer active.

#27
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by sixpax12*:

... getting a bunch of these.


Code:
[Sun Dec 03 09:25:14.297723 2017] [cgi:error] [pid 27660] [client 107.77.202.156:44461] AH01215: #6 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/I in /home/XXXX/info.XXXX.org/app/Composers/UserComposer.php on line 26: /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:25:14.297644 2017] [cgi:error] [pid 27660] [client 107.77.202.156:44461] AH01215: #5 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/Illuminate/View/Factory.php(510): Illuminate\\Events\\Dispatcher->fire('composing: syst...', Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:25:14.297552 2017] [cgi:error] [pid 27660] [client 107.77.202.156:44461] AH01215: #4 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/Illuminate/Events/Dispatcher.php(221): call_user_func_array(Object(Closure), Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:25:14.297401 2017] [cgi:error] [pid 27660] [client 107.77.202.156:44461] AH01215: #2 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/Illuminate/View/Factory.php(480): call_user_func_array(Array, Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:25:14.297263 2017] [cgi:error] [pid 27660] [client 107.77.202.156:44461] AH01215: #0 /home/XXXX/info.XXXX.org/app/Composers/UserComposer.php(26): Illuminate\\Foundation\\Bootstrap\\HandleExceptions->handleError(8, 'Trying to get p...', '/home/XXXX/info...', 26, Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:25:14.297079 2017] [cgi:error] [pid 27660] [client 107.77.202.156:44461] AH01215: PHP Fatal error:  Uncaught exception 'ErrorException' with message 'Trying to get property of non-object' in /home/XXXX/info.XXXX.org/app/Composers/UserComposer.php:26: /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:18:44.561882 2017] [cgi:error] [pid 28845] [client 107.77.202.156:58761] AH01215: #6 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/I in /home/XXXX/info.XXXX.org/app/Composers/UserComposer.php on line 26: /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:18:44.561784 2017] [cgi:error] [pid 28845] [client 107.77.202.156:58761] AH01215: #5 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/Illuminate/View/Factory.php(510): Illuminate\\Events\\Dispatcher->fire('composing: syst...', Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:18:44.561664 2017] [cgi:error] [pid 28845] [client 107.77.202.156:58761] AH01215: #4 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/Illuminate/Events/Dispatcher.php(221): call_user_func_array(Object(Closure), Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:18:44.561468 2017] [cgi:error] [pid 28845] [client 107.77.202.156:58761] AH01215: #2 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/Illuminate/View/Factory.php(480): call_user_func_array(Array, Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:18:44.561288 2017] [cgi:error] [pid 28845] [client 107.77.202.156:58761] AH01215: #0 /home/XXXX/info.XXXX.org/app/Composers/UserComposer.php(26): Illuminate\\Foundation\\Bootstrap\\HandleExceptions->handleError(8, 'Trying to get p...', '/home/XXXX/info...', 26, Array): /usr/local/cpanel/cgi-sys/ea-php56

* Restored post. It could be that the author is no longer active.

#28
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Hodor*:

Tell me why the list of Battlefield 3 players is not displayed&
2017-12-02_102804.png
In Battlefield 4 with this all right
2017-12-02_213215.png

I have the same in BF3 but before everything was fine. It is probably a problem in chat,stats logger plugin 1.0.0.3 version
* Restored post. It could be that the author is no longer active.

#29
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Hodor*:

See this post.

myrcon.net/...battlefield-admin-control-panel-for-adkats#entry52394

For me not working. Live scoreboard for BF3 still not working.
* Restored post. It could be that the author is no longer active.

#30
ImportBot

ImportBot

    Advanced Member

  • Friendly Neighborhood Bot
  • 52428 posts
Originally Posted by Prophet731*:

... getting a bunch of these.


Code:

[Sun Dec 03 09:25:14.297723 2017] [cgi:error] [pid 27660] [client 107.77.202.156:44461] AH01215: #6 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/I in /home/XXXX/info.XXXX.org/app/Composers/UserComposer.php on line 26: /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:25:14.297644 2017] [cgi:error] [pid 27660] [client 107.77.202.156:44461] AH01215: #5 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/Illuminate/View/Factory.php(510): Illuminate\\Events\\Dispatcher->fire('composing: syst...', Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:25:14.297552 2017] [cgi:error] [pid 27660] [client 107.77.202.156:44461] AH01215: #4 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/Illuminate/Events/Dispatcher.php(221): call_user_func_array(Object(Closure), Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:25:14.297401 2017] [cgi:error] [pid 27660] [client 107.77.202.156:44461] AH01215: #2 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/Illuminate/View/Factory.php(480): call_user_func_array(Array, Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:25:14.297263 2017] [cgi:error] [pid 27660] [client 107.77.202.156:44461] AH01215: #0 /home/XXXX/info.XXXX.org/app/Composers/UserComposer.php(26): Illuminate\\Foundation\\Bootstrap\\HandleExceptions->handleError(8, 'Trying to get p...', '/home/XXXX/info...', 26, Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:25:14.297079 2017] [cgi:error] [pid 27660] [client 107.77.202.156:44461] AH01215: PHP Fatal error:  Uncaught exception 'ErrorException' with message 'Trying to get property of non-object' in /home/XXXX/info.XXXX.org/app/Composers/UserComposer.php:26: /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:18:44.561882 2017] [cgi:error] [pid 28845] [client 107.77.202.156:58761] AH01215: #6 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/I in /home/XXXX/info.XXXX.org/app/Composers/UserComposer.php on line 26: /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:18:44.561784 2017] [cgi:error] [pid 28845] [client 107.77.202.156:58761] AH01215: #5 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/Illuminate/View/Factory.php(510): Illuminate\\Events\\Dispatcher->fire('composing: syst...', Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:18:44.561664 2017] [cgi:error] [pid 28845] [client 107.77.202.156:58761] AH01215: #4 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/Illuminate/Events/Dispatcher.php(221): call_user_func_array(Object(Closure), Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:18:44.561468 2017] [cgi:error] [pid 28845] [client 107.77.202.156:58761] AH01215: #2 /home/XXXX/info.XXXX.org/vendor/laravel/framework/src/Illuminate/View/Factory.php(480): call_user_func_array(Array, Array): /usr/local/cpanel/cgi-sys/ea-php56
[Sun Dec 03 09:18:44.561288 2017] [cgi:error] [pid 28845] [client 107.77.202.156:58761] AH01215: #0 /home/XXXX/info.XXXX.org/app/Composers/UserComposer.php(26): Illuminate\\Foundation\\Bootstrap\\HandleExceptions->handleError(8, 'Trying to get p...', '/home/XXXX/info...', 26, Array): /usr/local/cpanel/cgi-sys/ea-php56

Are the tables setup in the database for 2.1? That error is saying that it can't find the current user locale so i'm assuming the records didn't get created. Try re-running that SQL script posted above after you removed the bfacp? tables that exist.

I have the same in BF3 but before everything was fine. It is probably a problem in chat,stats logger plugin 1.0.0.3 version

For me not working. Live scoreboard for BF3 still not working.

The problem with BF3 is that they updated the game and added an additional entry to the player response with broke that version. The one I posted should be the fixed version. If not try the solution that Checka posted here. You'll make that change in the BF3Conn file.

Yeah I already solved this problem by changing in line 2709 the "10" into a "9" and everything was fine.


* Restored post. It could be that the author is no longer active.



Also tagged with one or more of these keywords: BF3, BF4, BFH, AdKats

3 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users


    Bing (1)