Jump to content

Ultimate Map Manager (1.2.5.0 - 03/26/15)


Prophet731

Recommended Posts

Originally Posted by Cornholeo*:

 

To everyone asking: The BF4.def file ON YOUR LAYER must be up-to-date. If you see the maps in PRoCon, but not in UMM, that means the BF4.def file on your computer is up-to-date, but the one on your layer is not.

 

You can upload the one from the Configs file on your PC to the Configs file on your layer server to resolve the issue.

 

If you don't have access to your layer's Configs folder, then you really should get a new layer provider, because that's stupid. But, if you don't want to do that, you're going to have to pester them until they get it updated properly for you.

Ok thanks that helps me.
* Restored post. It could be that the author is no longer active.
Link to post
  • Replies 2.5k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Description This plug-in is intended to manage your map rotation based upon the number of players on the server. Optionally, it will also change the server name to match the current rotation, allow ce

Posted Images

Originally Posted by Cornholeo*:

 

To everyone asking: The BF4.def file ON YOUR LAYER must be up-to-date. If you see the maps in PRoCon, but not in UMM, that means the BF4.def file on your computer is up-to-date, but the one on your layer is not.

 

You can upload the one from the Configs file on your PC to the Configs file on your layer server to resolve the issue.

 

If you don't have access to your layer's Configs folder, then you really should get a new layer provider, because that's stupid. But, if you don't want to do that, you're going to have to pester them until they get it updated properly for you.

I uploaded the bf4.def file from my pc to layer. I opened the file uploaded to confirm it was the updated and it is, showing the new maps in the file. It still does not show the new maps in UMM. I did this with procon stopped and then a restart on the layer.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by falcontx*:

 

I uploaded the bf4.def file from my pc to layer. I opened the file uploaded to confirm it was the updated and it is, showing the new maps in the file. It still does not show the new maps in UMM. I did this with procon stopped and then a restart on the layer.

You need to close your local PRoCon completely, restart your layer server, then start your local PRoCon again and reconnect.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Cornholeo*:

 

You need to close your local PRoCon completely, restart your layer server, then start your local PRoCon again and reconnect.

Did exactly as instructed above, no go. The bf4.def file is in config file on layer. There is also one in update folder, does it need to be updated as well? Its date is 26 Oct.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by LtMatt81*:

 

Falcon i need your help please. I have the latest version thats for donaters.

 

The problem ive got is this morning i manually added the new dlc maps to our server so we could play before procon etc got updated. It worked fine. However i tried to setup using Ultimate map manager and it didnt like it.Suddenly there is no options to select in ultimate map manager. So i tried to reinstall it, but the old settings remain. I stopped our layer, deleted all the files i could find relating to UMM, then reinstalled it and restarted the layer but somehow the old settings still remain. Help.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by falcontx*:

 

Falcon i need your help please. I have the latest version thats for donaters.

 

The problem ive got is this morning i manually added the new dlc maps to our server so we could play before procon etc got updated. It worked fine. However i tried to setup using Ultimate map manager and it didnt like it.Suddenly there is no options to select in ultimate map manager. So i tried to reinstall it, but the old settings remain. I stopped our layer, deleted all the files i could find relating to UMM, then reinstalled it and restarted the layer but somehow the old settings still remain. Help.

You need to edit your server config file (ip_address.cfg) and delete all of the lines related to UMM, or at least the map lists.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by falcontx*:

 

Did exactly as instructed above, no go. The bf4.def file is in config file on layer. There is also one in update folder, does it need to be updated as well? Its date is 26 Oct.

I don't know, man. Normally there's not an update folder.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by LtMatt81*:

 

You need to edit your server config file (ip_address.cfg) and delete all of the lines related to UMM, or at least the map lists.

Where do i find that?
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Cornholeo*:

 

Falcon I got it figured out. For some reason just uploading my file was not working. I downloaded layer file and copy/paste the data from my file over, then uploaded. That worked. Does not make sense but it worked. Thanks for the help, the donation has been money well spent on a great pluing!

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Mish_poLy*:

 

Im seeing an issue with UMM not being able to keep the UMM Map List in ProCon.

 

It will set the UMM Map List but after one or two maps, the UMM Map List disappears from ProCon's MapList tab and the maps from the server's maplist.txt show up as the only maps/game modes to be played.

 

In other words, the maplist.txt maps are overruling UMM's MapLists.

 

It is as if the "refresh the map list by reloading the maplist.txt" green arrows are being triggered to replace UMM's MapList with the maps from the server's maplist.txt.

 

Have you guys noticed what I described above?

We're seeing the same thing. Restarting both the server and procon layers haven't been able to fix it. It runs the UMM list for 1-2 rounds then back to the default maplist.txt.

 

Any thoughts yet?

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Cornholeo*:

 

Have not seen this yet. One thing I am seeing since we got the UMM to work with the new maps is Firestorm will only come up if you have it listed as Shanghi and Shanghi comes up when you have Firestorm listed.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Cornholeo*:

 

I had tons of problems with the UMM and the new rotation, it never cycled correctly today. We would have count needed to run second map list and it would stay on first. It has been a pain in the ass today.

 

We run 32 player conquest until we reach 25 players then it kicks into 64 player maps.

 

If it drops to 22 players on the 64 player rotation it will drop back down to first map list.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by pharbehind*:

 

Getting the same map list override problem as well, causing some headaches. I'll be posting the bug report tomorrow now that I have logging enabled.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by memickey*:

 

We had the same problem after the update yesterday. We are running 3 maplists like this :

0-1 players : CQ Large (one map - Siege Of Shanghai)

2-15 players : TDM (4 maps)

16-64 players : Mixed CQ and Rush (16 maps)

We are also running xVotemap when more than 32 players.

I have "Enable debug output" enabled on UMM at all times but yesterday NOTHING came out from the plugin when we were at the last maprotation. When I checked my server at Multiplay and Battlelog only one map was listed (Siege of Shanghai) and this map was run all evening yesterday.

I was able to force the server into applying the maplist once but after one other map it returned to Shanghai only.

 

I am running the Procon layer at home and I know that everything is done directly on the layer.

The strange thing is that we never got a mapvote yesterday even if I tried to force xVotemap.

The problem with the maprotation is present even if I disabled all other pluging in Procon.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by eddtheduck*:

 

also having trouble with UMM .loosing map lists only have two . but it also seems to make up its own as well!! it wither fills it up with rush or mixes the new maps with a list that has been deleted !!

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by staazvaind*:

 

To everyone asking: The BF4.def file ON YOUR LAYER must be up-to-date. If you see the maps in PRoCon, but not in UMM, that means the BF4.def file on your computer is up-to-date, but the one on your layer is not.

 

You can upload the one from the Configs file on your PC to the Configs file on your layer server to resolve the issue.

 

If you don't have access to your layer's Configs folder, then you really should get a new layer provider, because that's stupid. But, if you don't want to do that, you're going to have to pester them until they get it updated properly for you.

i quoted you to my hoster and they just answered that their layers update automatically.

so after one day i should have the def file on the layers (at least 10 full restarts).

 

so i started a layer on my own computer with a definitely up2date def file

and UMM does not show the new maps, m8.

 

the plugin not working right now is a pretty deep impact for me right now

as the additional preset after map loaded helped to make transport vehicles spawn

on my inf-only server.

 

 

/edit:

 

on a sidenote:

going through the def file right now...

isnt it interesting that dice named the 2nd assault XP0 instead of XP2 ? :ohmy:

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by EBassie*:

 

We have new maplist in lists,new maps not listed in UMM ,so do i need to update anything any where ,we are with trinity gaming.

You need to make sure your layer has an up2date bf4.def file.

 

Sent from my GT-I9505 using Tapatalk

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Phil_K*:

 

my hoster claims its up2date.

any other possibility to check it via procon itself maybe ?

No, only via FTP if possible and open up BF4.def on your hosted procon.

If you look at the maplist tab the left side shows the maps defined in the BF4.def

but that is always what your local client provides and not what your layer server

has.

 

Btw, the actual BF4.def contains

Code:

(2014-02-18.02)
in the third line.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by falcontx*:

 

If the maps are not showing in UMM, your layer's BF4.def file is NOT up-to-date, regardless of what your layer provider is telling you. I'm not sure how I can make this more clear. I would highly recommend finding a new layer provider that will allow you direct access to the Configs folder. They're not hard to find.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Moli87*:

 

If the maps are not showing in UMM, your layer's BF4.def file is NOT up-to-date, regardless of what your layer provider is telling you. I'm not sure how I can make this more clear. I would highly recommend finding a new layer provider that will allow you direct access to the Configs folder. They're not hard to find.

Or you host Procon with your own VDS, where you can manage "everything" on your own. :ohmy:
* Restored post. It could be that the author is no longer active.
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Please review our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.