Jump to content

xVotemap 1.5.6.0


ImportBot

Recommended Posts

Originally Posted by RescuePhlax*:

 

I have the Issue that the Voting doesnt automatically Start.

I have to start the vote manually all the time.

 

[11:27:39 39] [xVotemap] Work: Level loaded: Last round detected, starting voting system

[11:28:26 20] [xVotemap] Info: Current gamemode is not recognised: Domination0

[11:28:56 22] [xVotemap] Info: Current gamemode is not recognised: Domination0

[11:29:26 17] [xVotemap] Info: Current gamemode is not recognised: Domination0

[11:29:46 49] [xVotemap] Info: Current gamemode is not recognised: Domination0

[11:30:16 90] [xVotemap] Info: Current gamemode is not recognised: Domination0

...

[11:38:23 98] [xVotemap] Info: Current gamemode is not recognised: Domination0

[11:38:54 37] [xVotemap] Info: Current gamemode is not recognised: Domination0

[11:39:14 96] [xVotemap] Work: Round Over: Stopping voting system

...

[11:40:27 97] [xVotemap] Info: Level loaded: Lancang Dam , Round 1 of 1

[11:40:27 97] [xVotemap] Work: Level loaded: Last round detected, starting voting system

 

But nothing happens.

 

Attachment 2657

 

can anyone help me pls?

 

Greetings

 

RescuePhlax

OK i got it... Domination is not supported from this plugin.

Changed my maps to conquest small and its working fine :smile:

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Ralphvd*:

 

on TDM i see this message in log:

 

[18:13:34 52] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[18:13:34 52] [xVotemap] Error: Der Index war außerhalb des Arraybereichs.

Got same message everytime new game starts:

 

[00:58:29 54] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[00:58:29 55] [xVotemap] Error: Index was outside the bounds of the array.

 

----------------------------------------------

When the banner comes in chat, i think he spams about 3-5 times very fast. Not just one time. Is this normal or bug?

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by COK3Z3RO*:

 

I uploaded the file "xVotemap.cs" to the "/procon/Plugins/BF4" folder via FTP and when I restart procon, I do not see it in my plugins list. Any ideas?

This is my problem, too. What is the fault? I restarted my server AND procon layer several times... with no effect. I don't understand the problem.

 

My hoster is gamed.de. I started a ticket in their support center... but I don't think it's a gamed.de problem.

 

PLEASE HELP!!!

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by COK3Z3RO*:

 

This is my problem, too. What is the fault? I restarted my server AND procon layer several times... with no effect. I don't understand the problem.

 

My hoster is gamed.de. I started a ticket in their support center... but I don't think it's a gamed.de problem.

 

PLEASE HELP!!!

I did just a reset of the procon layer ftp in gamed.de control panel. Then i reinstalled the needed plugins and now IT WORKS. Is there any known conflict between some plugins?

 

Somehow... I'm happy now. Hours and hours thinking about solving this problems... but now it works!!

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by grizzlybeer*:

 

I have the Issue that the Voting doesnt automatically Start.

I have to start the vote manually all the time.

 

[11:27:39 39] [xVotemap] Work: Level loaded: Last round detected, starting voting system

[11:28:26 20] [xVotemap] Info: Current gamemode is not recognised: Domination0

[11:28:56 22] [xVotemap] Info: Current gamemode is not recognised: Domination0

[11:29:26 17] [xVotemap] Info: Current gamemode is not recognised: Domination0

[11:29:46 49] [xVotemap] Info: Current gamemode is not recognised: Domination0

[11:30:16 90] [xVotemap] Info: Current gamemode is not recognised: Domination0

...

[11:38:23 98] [xVotemap] Info: Current gamemode is not recognised: Domination0

[11:38:54 37] [xVotemap] Info: Current gamemode is not recognised: Domination0

[11:39:14 96] [xVotemap] Work: Round Over: Stopping voting system

...

[11:40:27 97] [xVotemap] Info: Level loaded: Lancang Dam , Round 1 of 1

[11:40:27 97] [xVotemap] Work: Level loaded: Last round detected, starting voting system

 

But nothing happens.

 

Attachment 2657

 

can anyone help me pls?

 

Greetings

 

RescuePhlax

you are running an old version not supporting bf4 oder bf3 with dlcs. pls update

 

I did just a reset of the procon layer ftp in gamed.de control panel. Then i reinstalled the needed plugins and now IT WORKS. Is there any known conflict between some plugins?

 

Somehow... I'm happy now. Hours and hours thinking about solving this problems... but now it works!!

what other plugins are you running? are all of them bf4 ready yet?

 

unfortunatly i still get an error

my settings:

Attachment 2627

 

[18:10:06 32] xVotemap Enabled!

[18:10:50 31] [xVotemap] Info: Estimated voting start 231 seconds ago, @ 18:06:59

[18:11:02 46] [xVotemap] Work: Displayed next map

[18:11:02 49] [xVotemap] Info: Dawnbreaker [CQ] was removed from maplistoptions.

[18:11:02 62] [xVotemap] Info: No flexiblity in displayed map options

[18:11:03 24] [xVotemap] Info: Votemap Options: Rogue Transmission [CQ] | Zavod 311 [CQ] | Hainan Resort [CQ] | Lancang Dam [CQ]

 

[...]

 

[18:33:39 31] [xVotemap] Error: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.

[18:38:15 80] [xVotemap] Info: Votemap Options: Rogue Transmission [CQ] | Zavod 311 [CQ] | Hainan Resort [CQ] | Dawnbreaker [CQ]

[18:38:21 03] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[18:38:21 04] [xVotemap] Error: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.

[18:50:33 17] xVotemap Disabled =(

can you post the log when this is happening with debug level 5

 

This plugin is a hit and miss, i've got an issue where sometimes it doesnt initiate the voting process when the actual players count is not met in the server and in the plugin config "Maximum Players For start"

 

Say i have a 56+2 commander slot server. Lets put it this way there is 52 users connected at the time the plugin called for the voting process but it didn't start because it detected that for it to start the voting process it should be 56 users connected no more no less else it won't start. So what i did for it to work is to manually set the "Maximum Players for Start" with respect to your players connected at that time.

 

I'm not using a layer btw, im using the client hosted on a windows server.

 

thanks

"Maximum Players to start" includes commanders and spectators. so for a full conquest large server you should set this to 70. next update will set the default to 70. unfortunately the current default is still 64. pls set this value to 70

 

Someone point me where I'm going wrong here... I've been trying to fix/get this to work but I'm either missing something silly easy or overlooking.

 

I can't get the plugin to work on any of my servers; NFOServers is my host and I'm using their Map Cycle system (which I think might be my issue_).

 

21:53:36 10] [xVotemap] Info: Total rounds: 0

[21:53:36 11] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[21:53:36 15] [xVotemap] Error: Object reference not set to an instance of an object.

[21:53:36 15] [xVotemap] Info: Voting system enabled_: False

 

I saw the reply/post to just ignore it but it constantly keeps saying:

 

21:59:06 48] [xVotemap] Info: There are 68 players in the db.

[21:59:36 43] [xVotemap] Info: sent reservedSlotsList.list

[21:59:36 46] [xVotemap] Info: Skipping ServerInfo call because voting system is disabled.

[21:59:36 69] [xVotemap] Info: There are 67 players in the db.

im not fimiliar with the nfo map cycle system.

votemap uses whatever maps are visible to it (same as visible to procon) and offers options from this list to vote for.

the next map is then set to the map that won (using an index, not the name)

 

so this mechanism allows the plugin to work with maplist managing plugins (ultimate map manager and such)

but also requires that the maplist is not changed after the voting has started

 

When we do /v in-game it tells us that there's no voting in progress and the next vote is in 2 hours 45 minutes - Nothing in the plugin is set for that long... ?
first: set the debug level to 5 so we can see whats going on in detail, also please provide info like gamemode, tickets, map and your options

 

for the 2h 45m and let me guess sth9 seconds. this comes from 9999 seconds - (voting duration + time before end). so you wont find this setting, its just the starting value of the counter for the time remaining.

 

So my changes didn't fix the problem, it came back, it only went away when TDM was on round 1/2, I prefer TDM to be on single rounds so I changed it to 1 round and this error came back immediately...doesn't seem to be a problem with CQ rounds...

 

Hopefully we hear back from the dev team soon...

for tdm (any deathmatch mode) the plugin tries to calculate the remaining time until the end of the round and start the map vote according to your settings.

please set the debug level to 5 and post the log showing the error here. infos like gamemode, tickerts, players,... are also useful.

 

any chance that you can adjust the threshold based on percentage of users online rather than a static number?
could be an option for future versions. thank you

 

If your running a 64slot +2 commanders and 4 spectate=70 do I set the maximum players to start to 64 or 70?
70. the default value will be updated in the next version.

 

I don't understand why I keep getting error message : "[16:55:49 54] xVotemap Enabled!

[16:56:12 51] [xVotemap] Info: Not last round. Stopping voting system.

[16:56:12 52] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[16:56:12 53] [xVotemap] Error: Object reference not set to an instance of an object.

[19:28:31 70] xVotemap Disabled =(

[19:28:34 09] xVotemap Enabled!

[19:28:48 95] [xVotemap] Info: Not last round. Stopping voting system.

[19:28:48 95] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[19:28:48 95] [xVotemap] Error: Object reference not set to an instance of an object.

 

It worked for one map and hasn't worked ever since. What can I do to fix this? Everything was done correctly. Please help

please set the debug level to 5.

as far as i can see voting didnt start because it was not the last round.

 

are you sure you have the latest version and set all settings right? please verify that. you can also post a screenshot if you want

 

I was told this works on rush, just wondering when/if it works on obliteration?

I would test on my own server, however it is full and I have got some 'picky' players. That don't like me testing while they are on! aha :tongue:

should work on obliteration just the same as on conquest.

the map vote will start in the last round when a team has only 1 bomb site left. debug output is buggy for this mode (will jump from 2:45:39 to "now")

 

Thanks for updating this, made our server that much more popular, actually stayed live right through to 10am!
no problem :-)

 

not 100% on mine...

when vote banner doesnt appear and when the map options come up in chat it says a random player is admin saying it so the options overlap onto two lines...

 

any ideas?

random player displayed as admin is a known bug in the game chat not in a plugin.

can you post a screenshot of the lines overlapping? can you describe or better yet show the problem you are having?

 

 

for that setvotestartandendtimes error: im still looking into it. voting should still work on all modes and maps. please make sure all settings are correct.

however i will find the source of that message and fix it in the next update.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by skinnerhh*:

 

[12:02:35 69] xVotemap Enabled!

[12:02:40 74] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[12:02:40 76] [xVotemap] Error: Index was outside the bounds of the array.

[12:03:10 76] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[12:03:10 76] [xVotemap] Error: Index was outside the bounds of the array.

[12:03:40 76] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[12:03:40 76] [xVotemap] Error: Index was outside the bounds of the array.

[12:04:10 79] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[12:04:10 80] [xVotemap] Error: Index was outside the bounds of the array.

[12:04:40 80] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[12:04:40 80] [xVotemap] Error: Index was outside the bounds of the array.

 

[email protected]

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by rbtmarshall*:

 

[12:02:35 69] xVotemap Enabled!

[12:02:40 74] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[12:02:40 76] [xVotemap] Error: Index was outside the bounds of the array.

[12:03:10 76] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[12:03:10 76] [xVotemap] Error: Index was outside the bounds of the array.

[12:03:40 76] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[12:03:40 76] [xVotemap] Error: Index was outside the bounds of the array.

[12:04:10 79] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[12:04:10 80] [xVotemap] Error: Index was outside the bounds of the array.

[12:04:40 80] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[12:04:40 80] [xVotemap] Error: Index was outside the bounds of the array.

 

[email protected]

what are your setting in the :

Voting Duration

Time Between Voting

Voting start time

 

 

I remember getting that error when adjusting settings. I changed Voting Duration and made sure it was at least one second less than either of the other two.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by skinnerhh*:

 

what are your setting in the :

Voting Duration

Time Between Voting

Voting start time

 

 

I remember getting that error when adjusting settings. I changed Voting Duration and made sure it was at least one second less than either of the other two.

Voting Duration 240

Time Between Voting 180

Voting start time 600

 

These were the defaults....any suggestions for other settings?

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by rbtmarshall*:

 

Voting Duration 240

Time Between Voting 180

Voting start time 600

 

These were the defaults....any suggestions for other settings?

try it with voting duration lower than the other two. ex:179
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by rbtmarshall*:

 

Got same error, time between voting 179 didnt fix it.

 

Havent change those settings, default error

just by odd chance. do you have the multi-balancer plugin?

 

I just tried it out, and got this error message with votemap. then i removed multibalancer and i no longer get that error.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Ralphvd*:

 

just by odd chance. do you have the multi-balancer plugin?

 

I just tried it out, and got this error message with votemap. then i removed multibalancer and i no longer get that error.

Yes i have the MULTIbalancer - 1.0.7.0 running
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by MX-LO*:

 

So far so good the map is going to the voted map(i3d) but when we vote. the vote is correctly handled but we get Action: 3 is not found.

 

Where 3 is the voting number. How to fix this?

We got the same problem.

Can some tell what the problem is?

I3d server.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by rbtmarshall*:

 

Can you use two of the same maps but different modes, or will this cause conflicts with how the map names are used in this plugin?

 

 

ex:

MP_Flooded ConquestSmall0 1

MP_Flooded ConquestLarge0 1

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Fliedel*:

 

Hey, I have a little Problem :

 

I put the xVote File in the Plugin Folder of my ProCon but it dont appear in the Plugin List ...

What can cause this ?

 

Sorry for my english ^^

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by MX-LO*:

 

I got no more errors in procon.

I did this showthread....ll=1#post83069*.

 

Only still the server is crashing on mapswitch. If the mapvote is off the server doesn't crash.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by rbtmarshall*:

 

I can't find this button, where is it ?

are you using Procon Frostbite? if so its on the plugin's tab under the left box that has the plugins in it. the window could be squished, check if it can expand in borders if you cant see it.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by rbtmarshall*:

 

Can you use two of the same maps but different modes, or will this cause conflicts with how the map names are used in this plugin?

 

 

ex:

MP_Flooded ConquestSmall0 1

MP_Flooded ConquestLarge0 1

Just incase others are wondering, it seems to work. but there is no difference in the appearance in the vote:

 

ex if those two were in the vote they would both be Flood Zone options in the vote.

 

Would it be possible to add in a future update, the ability to have the map name followed by a appreviated map mode?

 

 

nice plugin by the way, thanks. its good to leave the option up to the players.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Kinsman*:

 

Getting this error since changing our server to (all) TDM Maps.

 

[11:13:36 16] [xVotemap] Error: EXCEPTION CAUGHT IN: SetVoteStartAndEndTimes

[11:13:36 16] [xVotemap] Error: Index was outside the bounds of the array.

[11:13:37 51] xVotemap Disabled =(

I disabled all other plugins, and got the same result as soon as Mapvote is enabled.

 

Is this because we run 32P perhaps?

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Mrwesth*:

 

Getting this error since changing our server to (all) TDM Maps.

 

 

 

I disabled all other plugins, and got the same result as soon as Mapvote is enabled.

 

Is this because we run 32P perhaps?

i see this problem aswell and im pretty sure its because TDM counts tickets from 0 to Limit and not from Limit to 0 so that Confuses the hell out of Votemap :P
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Fliedel*:

 

are you using Procon Frostbite? if so its on the plugin's tab under the left box that has the plugins in it. the window could be squished, check if it can expand in borders if you cant see it.

I have my PRocon Window all over my screen, but there is no Reload Plugins button ...
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Scarab*:

 

I continue to be amazed with the creativity and talent of plug in authors, and it boggles my mind how you guys write code to accomplish so many different tasks/options. This is just another incredibly helpful plug in.

 

Reading and searching through the thread, I can't seem to find a definition or explanation for the VIP VOTE COUNT option. If I set this to 3, does this mean I need 3 VIP's to Vote, or their Vote is worth 3 votes? What is it's true definition and function?

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Jackineyerack*:

 

can someone help me with a setting on this? Im not sure what to set the time between voting end and round end and coting start time from start of round, running a 64 conquest. The dislplay for voting doesnt seem to show up at all

* Restored post. It could be that the author is no longer active.
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Game Server Hosting:

      We're happy to announce that EZRCON will branch out into the game server provider scene. This is a big step for us so please having patience if something doesn't go right in this area. Now, what makes us different compared to other providers? Well, we're going with the idea of having a scaleable server hosting and providing more control in how you set up your server. For example, in Minecraft, you have the ability to control how many CPU cores you wish your server to have access to, how much RAM you want to use, how much disk space you want to use. This type of control can't be offered in a single service package so you're able to configure a custom package the way you want it.

      You can see all the available games here. Currently, we have the following games available.

      Valheim (From $1.50 USD)


      Rust (From $3.20 USD)


      Minecraft (Basic) (From $4.00 USD)


      Call of Duty 4X (From $7.00 USD)


      OpenTTD (From $4.00 USD)


      Squad (From $9.00 USD)


      Insurgency: Sandstorm (From $6.40 USD)


      Changes to US-East:

      Starting in January 2022, we will be moving to a different provider that has better support, better infrastructure, and better connectivity. We've noticed that the connection/routes to this location are not ideal and it's been hard getting support to correct this. Our contract for our two servers ends in March/April respectively. If you currently have servers in this location you will be migrated over to the new provider. We'll have more details when the time comes closer to January. The new location for this change will be based out of Atlanta, GA. If you have any questions/concerns please open a ticket and we'll do our best to answer them.
      • 1 reply
    • Hello All,

      I wanted to give an update to how EZRCON is doing. As of today we have 56 active customers using the services offered. I'm glad its doing so well and it hasn't been 1 year yet. To those that have services with EZRCON, I hope the service is doing well and if not please let us know so that we can improve it where possible. We've done quite a few changes behind the scenes to improve the performance hopefully. 

      We'll be launching a new location for hosting procon layers in either Los Angeles, USA or Chicago, IL. Still being decided on where the placement should be but these two locations are not set in stone yet. We would like to get feedback on where we should have a new location for hosting the Procon Layers, which you can do by replying to this topic. A poll will be created where people can vote on which location they would like to see.

      We're also looking for some suggestions on what else you would like to see for hosting provider options. So please let us know your thoughts on this matter.
      • 4 replies
    • Hi All,

      So seeing as Venice Unleased is released, I'm looking into if I should offer game hosting for it. I would like some feedback on this subject.

      VU - Experience Battlefield 3 like never before! (veniceunleashed.net)
      • 3 replies
    • So as the topic title says, should EZRCON offer general web hosting services?
      • 1 reply
    • Added ability to disable the new API check for player country info


      Updated GeoIP database file


      Removed usage sending stats


      Added EZRCON ad banner



      If you are upgrading then you may need to add these two lines to your existing installation in the file procon.cfg. To enable these options just change False to True.

      procon.private.options.UseGeoIpFileOnly False
      procon.private.options.BlockRssFeedNews False



       
      • 2 replies
×
×
  • Create New...

Important Information

Please review our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.