Jump to content

Ultimate Map Manager (1.2.5.0 - 03/26/15)


Prophet731

Recommended Posts

Originally Posted by falcontx*:

 

There is still some kind of bug with the presets:

 

[11:18:15 89] UltimateMapManager: TASK -> 20 players. Need to change to Map List 0 [sQDM ONLY].

[11:18:15 90] UltimateMapManager: WORK -> Changing to Map List 0 [sQDM ONLY].

[11:18:15 91] UltimateMapManager: WORK -> Setting server preset to Hardcore.

 

But my server:

I'll get this fixed in an update soon, but for now, just make a custom preset that has only one line:

vars.preset hardcore

 

EDIT: In my testing, changing the number of tickets to anything other than 100% also results in a "Custom" server.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by salty21db*:

 

It seems I have to post every day in one thread or another, so here goes... If you don't post a proper bug report, I'm just going to ignore whatever you post because I can't help you. Read this: showthread....a-plugin-issue*

Current 1.2.2.6 version of plugin

consolepluginlog.zipProcon 1.4.1.1

Hosted by Fragnet

70 slot server

Don't know how to show settings or take a screenshot that will encompass all settings.

Map list is not switching over once it hits 33+ when it is set to "change map list only after map has complete its total number of rounds." If switched to "change map immediately" it will change to the correct map list.

19:16 and 19:49

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by falcontx*:

 

Current 1.2.2.6 version of plugin

consolepluginlog.zipProcon 1.4.1.1

Hosted by Fragnet

70 slot server

Don't know how to show settings or take a screenshot that will encompass all settings.

Map list is not switching over once it hits 33+ when it is set to "change map list only after map has complete its total number of rounds." If switched to "change map immediately" it will change to the correct map list.

19:16 and 19:49

The plugin log you included was empty, which means you probably don't have the UMM debug messages enable? Or maybe it's not enabled at all? Hard to tell. Also, your console log contains no events. Please read the link I posted again and follow all of the instructions so that your logging is set up properly.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by salty21db*:

 

The plugin log you included was empty, which means you probably don't have the UMM debug messages enable? Or maybe it's not enabled at all? Hard to tell. Also, your console log contains no events. Please read the link I posted again and follow all of the instructions so that your logging is set up properly.

Debug messages are enabled, plugin is enabled as well. Console I don't know...I'll just wait until someone reports the same issue because clearly I have no idea what I'm doing, all I know is it isn't working when "waiting for last round" but is working when "switch map immediately" is enabled.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by falcontx*:

 

Debug messages are enabled, plugin is enabled as well. Console I don't know...I'll just wait until someone reports the same issue because clearly I have no idea what I'm doing, all I know is it isn't working when "waiting for last round" but is working when "switch map immediately" is enabled.

I don't know why your plugin console log was empty then. It should have had messages from UMM regarding what it was doing.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by WDT-TardFarmer*:

 

Just a note to anyone trying to get the logging to work. I did not see the log folder after I made the edits in the procon.cfg and the ip address.cfg. You have to turn off the procon layer completely before you make your edits. (I host mine at home on a server so I did not ftp the files down ) Once I made the edits with the layer turned off the stuck and the logs folder was created once I turned the layer back on. Hope this helps someone.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by WDT-TardFarmer*:

 

here are my logs:

 

UMM Version 1.2.2.6

Procon version 1.4.1.1

Game provider = NFO

64 player server

I run my procon layer from my server at home with necessary ports opened on my asa

 

We are playing in conquest only. UMM does not control the mapcycle, I must be missing something simple. I only use one mapcycle currently "test"

 

I am NOT using the NFO map cycle tool built into the server setup.

 

The maps should have 2 rounds each but there are only 1. The map cycle does not follow the maplist of UMM either. In the screenshot that I attached, on the left you can see the maplist the server is actually following and the the UMM config which is what it should be using. Let me know if you need anything else.

 

 

 

EDIT:

 

I may have found the reason. I uploaded a screenshot of my NFO server Easy setup page. There is a preset mapcycle which is required to get the quickplay. I highlighted the info on it. Is there a way to add this setting to UMM so we can stillget quickplay traffic?

 

I added in : vars.mpExperience CQCLASSIC to UMM

 

and disabled it on NFO. I then restarted the server. Still no luck

 

Attached Files:

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by falcontx*:

 

here are my logs:

 

UMM Version 1.2.2.6

Procon version 1.4.1.1

Game provider = NFO

64 player server

I run my procon layer from my server at home with necessary ports opened on my asa

 

We are playing in conquest only. UMM does not control the mapcycle, I must be missing something simple. I only use one mapcycle currently "test"

 

I am NOT using the NFO map cycle tool built into the server setup.

 

The maps should have 2 rounds each but there are only 1. The map cycle does not follow the maplist of UMM either. In the screenshot that I attached, on the left you can see the maplist the server is actually following and the the UMM config which is what it should be using. Let me know if you need anything else.

 

 

 

EDIT:

 

I may have found the reason. I uploaded a screenshot of my NFO server Easy setup page. There is a preset mapcycle which is required to get the quickplay. I highlighted the info on it. Is there a way to add this setting to UMM so we can stillget quickplay traffic?

Thanks for the detailed report. Looking at the logs, the plugin log says that UMM changed the map list, but there are no maplist clear or add commands in the console log. I've never seen this before and have no idea why it would be doing this. One thing you should know is that maplist.txt will never be changed, though. The correct way to view the current maplist is to change to the Lists/Maps tab in PRoCon.

 

As far as NFO goes, based on the tooltip, it seems that you should be able to change the map list after the server starts, so I don't really see an issue there.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Kenturrac*:

 

mine do not start correctly. if I have votemap active its not working at all. for example a rush preset for rush maps, and one for tdm and so on. it never loads the right one. seems like that its just not working with votemap... which sucks hard!!!

and since today its also not working at all anymore. it always loads the same preset instead of one for rush, one for tdm and so on... annoys me since it should make my life easier...

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by falcontx*:

 

For those having issues, I need a proper bug report in order to help you.

showthread....a-plugin-issue*

 

I send it as soon as I go through my email. I've been gone all day, but I'm going through it now.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by canadaka*:

 

I'm having some problems with UMM. It seems it takes several rounds for UMM to switch to a new maplist. Say i have a starting list 0-10 players and another one 10-24. At the end of a round there might be 16 players yet it doesn't switch to the larger maplist. next round there is also >10 players, say 18, still no change. But then sometimes on the 3rd map it might change, seems kinda random. Is UMM supposed to switch immediately? I have all the maps only set to 1 round and the "change map list only after map has complet it total" set too "no".

 

When does UMM check the number of players and decide if a maplist change is needed? At the score screen? Right when it starts loading? I'm wondering if a round had 20 players, but on the scorescreen 10 players left, and you had a maplist that had a minimum set to something in-between those, what happens?

 

The second issues is probably related to the above.

 

I had xVotemap enabled and it seems that when a map is voted on the server always plays that map, even if the number of players on the server has increased to a level that should have loaded a different map list.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by salty21db*:

 

I'm having some problems with UMM. It seems it takes several rounds for UMM to switch to a new maplist. Say i have a starting list 0-10 players and another one 10-24. At the end of a round there might be 16 players yet it doesn't switch to the larger maplist. next round there is also >10 players, say 18, still no change. But then sometimes on the 3rd map it might change, seems kinda random. Is UMM supposed to switch immediately? I have all the maps only set to 1 round and the "change map list only after map has complet it total" set too "no".

 

When does UMM check the number of players and decide if a maplist change is needed? At the score screen? Right when it starts loading? I'm wondering if a round had 20 players, but on the scorescreen 10 players left, and you had a maplist that had a minimum set to something in-between those, what happens?

 

The second issues is probably related to the above.

 

I had xVotemap enabled and it seems that when a map is voted on the server always plays that map, even if the number of players on the server has increased to a level that should have loaded a different map list.

That would be my issue as well but I couldn't report the issue well enough :sad:.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Ralphvd*:

 

If you want to switch preset. i suggest you to turn it on like this:

 

Preset 1 --> 0 - 20

Preset 2 --> 16-32*

 

* is max slot.

 

Now it goes till 20 players preset 1, if 20+ players it will go to preset 2. If preset 2 has less than 16 players it will fall back to preset 1.

( so it has some limit in falling down in presets).

 

UMM checks just some secs before the game starts(at the end of every game). In this moment he checks the amount of players and switches to the preset you wanted.

 

For your 2nd problem, this is because votemap is using the maplist like it is. So if you are playing preset 1(sqdm for example). He will only use maps in the preset 1.

But if you change your preset. Votemap still goes to the same map, only the mode you wanted(depends on the settings btw, you can setup to start everytime with same map, or randomize or the next map in the list.)

 

I hope it is a bit clear, english is not my native language. :mad:

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by kcuestag*:

 

Hi what's the time using the plugin?

Not change the list based on the time

Thank you

You set either the time of the machine the Procon is hosted at, or you can use different time zones. :smile:
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by salty21db*:

 

If you want to switch preset. i suggest you to turn it on like this:

 

Preset 1 --> 0 - 20

Preset 2 --> 16-32*

 

* is max slot.

 

Now it goes till 20 players preset 1, if 20+ players it will go to preset 2. If preset 2 has less than 16 players it will fall back to preset 1.

( so it has some limit in falling down in presets).

 

UMM checks just some secs before the game starts(at the end of every game). In this moment he checks the amount of players and switches to the preset you wanted.

 

For your 2nd problem, this is because votemap is using the maplist like it is. So if you are playing preset 1(sqdm for example). He will only use maps in the preset 1.

But if you change your preset. Votemap still goes to the same map, only the mode you wanted(depends on the settings btw, you can setup to start everytime with same map, or randomize or the next map in the list.)

 

I hope it is a bit clear, english is not my native language. :mad:

I have a gap between mine. Mine will set on 48 sometimes even though the first map list is to switch to the second at 33+. I've tried every different setup I can think of. The only time it will switch is if I set it to "switch map immediately." Sometimes it will also randomly work, but I don't do anything to make that happen lol.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by DrFellatio*:

 

Switching from CQ to Rush works fine for the 1st round. but the second rush round goes back to default ticketcount even if commands sent every round is enabled... And even if XVotemap is deactivated.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by DarkOzon*:

 

Hi, I've seem to have a problem related to ASS and UMM.

 

When round starts and both ASS and UMM plugins are enabled, its seems to go in to a round restart loop. Also happens sometimes with only UMM enabled, but usually when both is enabled.

UMM restarts the map atleast for 3-5 times and then you can spawn.

To remedy the situation I have to disable both ASS and UMM.

Anyone else had this problem?

 

UMM has two MAP lists, CQ Small for when the server is less than 32 players, and CQ Large for 26-64 Players.

ASS is setup with 32 players 0 - 32 , 64 Players at 26+

 

UMM Settings:

Enable map list manager: Set to YES

Change map list only after map has completed it's total number of rounds: Set to YES

CQ Small Map List: 0 - 32

CQ Large Map List: 26 - 64

 

ASS:

Enable adaptive server size: YES

On startup, assume round started at max server size: YES

Display welcome/join messages to help start server: YES

32 Player 0 - 25 and 64 Players 26 - 64.

 

Note: We're running R11 (TEST/QA) on server.

 

UMM seems to go into a round restart loop when ASS is enabled.

 

[00:45:06 54] UltimateMapManager: INFO -> Next round requested. Rounds run on this map list: 1

[00:46:54 41] UltimateMapManager: INFO -> Round restart requested. Rounds run on this map list: 2

[00:47:06 85] UltimateMapManager: INFO -> Round restart requested. Rounds run on this map list: 3

--SNIP--

[01:06:59 35] UltimateMapManager: INFO -> Round restart requested. Rounds run on this map list: 60

[01:07:37 43] UltimateMapManager: INFO -> Round restart requested. Rounds run on this map list: 61

[01:08:30 54] UltimateMapManager: INFO -> Round restart requested. Rounds run on this map list: 62

Im gona submit a proper bugreport when I have the time to do some extra tests.

 

Cheers,

DarkOzon

* Restored post. It could be that the author is no longer active.
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Game Server Hosting:

      We're happy to announce that EZRCON will branch out into the game server provider scene. This is a big step for us so please having patience if something doesn't go right in this area. Now, what makes us different compared to other providers? Well, we're going with the idea of having a scaleable server hosting and providing more control in how you set up your server. For example, in Minecraft, you have the ability to control how many CPU cores you wish your server to have access to, how much RAM you want to use, how much disk space you want to use. This type of control can't be offered in a single service package so you're able to configure a custom package the way you want it.

      You can see all the available games here. Currently, we have the following games available.

      Valheim (From $1.50 USD)


      Rust (From $3.20 USD)


      Minecraft (Basic) (From $4.00 USD)


      Call of Duty 4X (From $7.00 USD)


      OpenTTD (From $4.00 USD)


      Squad (From $9.00 USD)


      Insurgency: Sandstorm (From $6.40 USD)


      Changes to US-East:

      Starting in January 2022, we will be moving to a different provider that has better support, better infrastructure, and better connectivity. We've noticed that the connection/routes to this location are not ideal and it's been hard getting support to correct this. Our contract for our two servers ends in March/April respectively. If you currently have servers in this location you will be migrated over to the new provider. We'll have more details when the time comes closer to January. The new location for this change will be based out of Atlanta, GA. If you have any questions/concerns please open a ticket and we'll do our best to answer them.
      • 1 reply
    • Hello All,

      I wanted to give an update to how EZRCON is doing. As of today we have 56 active customers using the services offered. I'm glad its doing so well and it hasn't been 1 year yet. To those that have services with EZRCON, I hope the service is doing well and if not please let us know so that we can improve it where possible. We've done quite a few changes behind the scenes to improve the performance hopefully. 

      We'll be launching a new location for hosting procon layers in either Los Angeles, USA or Chicago, IL. Still being decided on where the placement should be but these two locations are not set in stone yet. We would like to get feedback on where we should have a new location for hosting the Procon Layers, which you can do by replying to this topic. A poll will be created where people can vote on which location they would like to see.

      We're also looking for some suggestions on what else you would like to see for hosting provider options. So please let us know your thoughts on this matter.
      • 4 replies
    • Hi All,

      So seeing as Venice Unleased is released, I'm looking into if I should offer game hosting for it. I would like some feedback on this subject.

      VU - Experience Battlefield 3 like never before! (veniceunleashed.net)
      • 3 replies
    • So as the topic title says, should EZRCON offer general web hosting services?
      • 1 reply
    • Added ability to disable the new API check for player country info


      Updated GeoIP database file


      Removed usage sending stats


      Added EZRCON ad banner



      If you are upgrading then you may need to add these two lines to your existing installation in the file procon.cfg. To enable these options just change False to True.

      procon.private.options.UseGeoIpFileOnly False
      procon.private.options.BlockRssFeedNews False



       
      • 2 replies
×
×
  • Create New...

Important Information

Please review our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.