Jump to content

Ultimate Map Manager (1.2.5.0 - 03/26/15)


Prophet731

Recommended Posts

Originally Posted by falcontx*:

 

We are having some issues with UMM.

 

1. UMM does not seem to correctly set tickets after Chain Link or Rush when it switches to Conquest Large.

 

We set Rush and CL to:

 

Code:

vars.gameModeCounter 300
The issue is, when a Conquest Large map loads after Rush or CL, it does not reset the ticket count to 1000 (100%). So every Conquest Large Map that loads after Rush or Chain Link gets set to roughly 2400 tickets.

 

I have attempted to send 100% presets after the round has loaded, but that wont do it either.

 

2. UMM does not seem to be able to handle both player count AND time of day.

 

We would like the server to:

05:00 - 14:59 Run Map List A IF there are 1-19 players on.

00:00 - 23:59 Run Map List B IF there 20-64 players on.

 

Basically we only want map list A list to run in the morning, but only if there are

1. Is UMM not sending the command? Or is your server just not responding the way you want? Check your logs to see what the server's response to the command UMM sends is.

 

2. This should work. What are you experiencing?

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by OddJob001*:

 

1. Is UMM not sending the command? Or is your server just not responding the way you want? Check your logs to see what the server's response to the command UMM sends is.

 

2. This should work. What are you experiencing?

1. Is UMM not sending the command? Or is your server just not responding the way you want? Check your logs to see what the server's response to the command UMM sends is.

 

2. This should work. What are you experiencing?

So I just spent the last hour testing this. I can see in the console that the command is set. I can even see in the Server Settings > Gameplay that the GameModeCounter shows 300%. However, the tickets are still only 750. Now, when I create a new preset, and set ONLY the vars.gamemodecounter to 3000, it will set the chain link tickets to 3000. The issue is, when we go to run the next CQL map, it will keep those 3000 tickets and then ADD however many more tickets the CQL is set to. Basically as it is right now, I cant seem to come up with any exact pattern as to how it works. It just makes no sense. Seems totally random.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by falcontx*:

 

So I just spent the last hour testing this. I can see in the console that the command is set. I can even see in the Server Settings > Gameplay that the GameModeCounter shows 300%. However, the tickets are still only 750. Now, when I create a new preset, and set ONLY the vars.gamemodecounter to 3000, it will set the chain link tickets to 3000. The issue is, when we go to run the next CQL map, it will keep those 3000 tickets and then ADD however many more tickets the CQL is set to. Basically as it is right now, I cant seem to come up with any exact pattern as to how it works. It just makes no sense. Seems totally random.

Yeah, it's a server issue. UMM is sending the command and it's shown in the console and reflected in PRoCon, but the server is ignoring it for whatever reason. The only thing that can really be played with is when the command it sent, which requires going into the code. Some posts up, I explained how to do this for someone else who was having a similar issue.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by eddtheduck*:

 

Yeah, it's a server issue. UMM is sending the command and it's shown in the console and reflected in PRoCon, but the server is ignoring it for whatever reason. The only thing that can really be played with is when the command it sent, which requires going into the code. Some posts up, I explained how to do this for someone else who was having a similar issue.

oddjob . i have the change off codes and got it to send 3 times over 10/20/30 sec intervals but still does not accept command
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by OddJob001*:

 

oddjob . i have the change off codes and got it to send 3 times over 10/20/30 sec intervals but still does not accept command

Whats strange is sometimes it accept it (usually when CQL has ran at least twice in a row, or when it switches to Chain Link). But never when it goes from Chain Link/Rush to CQL.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by eddtheduck*:

 

Yeah. now that I've looked at the code, that wouldn't work. Try adding this on the next line (1722):

Code:

this.ExecuteCommand("procon.protected.tasks.add", "CUltimateMapManager", "11", "1", "1", "procon.protected.plugins.call", "CUltimateMapManager", "CheckPreset");
And, on line 1811, change "private" to "public".

 

Then, it should work, as long as you have "Send preset commands after every round_" set to "Yes".

here is what i done
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by falcontx*:

 

At me the plugin from Hogwarts ...

 

Why normal? It's Infantry preset! I think that the plugin does not considers vars. commands correctly!

If you looked at the logs you sent, you would see that the "vars.preset infantry" command was sent, but that the server responded "ExecutedOnNextRound", which means that the command was sent too late. Check out previous posts in this thread regarding changing the timing of the commands.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Hodor*:

 

If you looked at the logs you sent, you would see that the "vars.preset infantry" command was sent, but that the server responded "ExecutedOnNextRound", which means that the command was sent too late. Check out previous posts in this thread regarding changing the timing of the commands.

Now I'll record to you on a video bug in your plugin .....
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Hodor*:

 

I created 2 maps typed 4 people and completed round, the next map Zavod Infantry Only - still loaded Normal mode!

 

Code:

[20:54:03] UltimateMapManager: TASK -> 0 players. Need to change to Map List 0 [New Map List].
[20:54:03] UltimateMapManager: WORK -> Changing to Map List 0 [New Map List].
[20:54:04] UltimateMapManager: WORK -> Next map: Lancang Dam (Conquest Small). Setting server preset to Normal.
[20:54:06] UltimateMapManager: INFO -> Next round requested. Rounds run on this map list: 0
[20:54:07] UltimateMapManager: WORK -> Next map: Lancang Dam (Conquest Small). Setting server preset to Normal.
[20:54:09] UltimateMapManager: INFO -> Level loaded.
[20:54:09] [AdKats] SUCCESS: Old round ID: 7
[20:54:09] [AdKats] SUCCESS: New round ID: 8
[20:56:05] CD - weapon avg accuracy not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[20:56:05] CD - weapon avg headshots/kill not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[20:56:05] CD - weapon avg kills/hit not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[20:56:05] CD - weapon avg kills/min not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[20:57:03] PB Hack Logger Now watching for hackers!
[20:59:09] CD - weapon avg accuracy not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[20:59:09] CD - weapon avg headshots/kill not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[20:59:09] CD - weapon avg kills/hit not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[20:59:09] CD - weapon avg kills/min not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[21:00:10] CD - weapon avg accuracy not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[21:00:10] CD - weapon avg headshots/kill not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[21:00:10] CD - weapon avg kills/hit not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[21:00:10] CD - weapon avg kills/min not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[21:00:36] UltimateMapManager: INFO -> Level loaded.
[21:00:36] UltimateMapManager: INFO -> Round restart requested. Rounds run on this map list: 1
[21:00:37] UltimateMapManager: WORK -> Next map: Lancang Dam (Conquest Small). Setting server preset to Normal.
[21:00:37] UltimateMapManager: INFO -> Level loaded.
[21:00:41] CD - weapon avg accuracy not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[21:00:41] CD - weapon avg headshots/kill not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[21:00:41] CD - weapon avg kills/hit not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[21:00:41] CD - weapon avg kills/min not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[21:02:43] CD - weapon avg accuracy not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[21:02:43] CD - weapon avg headshots/kill not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[21:02:43] CD - weapon avg kills/hit not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[21:02:43] CD - weapon avg kills/min not found: WARSAW_ID_P_XP4_INAME_KNIFEWEAVER
[21:03:03] UltimateMapManager: INFO -> Round ended. Rounds run on this map list: 2
[21:03:14] UltimateMapManager: WORK -> Next map: Zavod 311 (Conquest Small). Setting server preset to Custom Preset: Infantry.
[21:04:07] [AdKats] SUCCESS: Old round ID: 7
[21:04:07] [AdKats] SUCCESS: New round ID: 8
[21:04:07] UltimateMapManager: INFO -> Level loaded.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Hodor*:

 

@falcontx I found bug with presets!

 

If i put vars.gameModeCounter 100 in "Custom Preset: Infantry Only 1" then preset Infantry Only will not start!

Dont forget about 1080p

 

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by falcontx*:

 

The plugin is broken

There's nothing wrong with the plugin. Your server is broken.

 

I've been busy and haven't had a chance to look into your problem directly.

 

Don't be a jerk.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by ColColonCleaner*:

 

There's nothing wrong with the plugin. Your server is broken.

 

I've been busy and haven't had a chance to look into your problem directly.

 

Don't be a jerk.

He's known for demanding updates to serve his needs immediately without giving anything back. Just his thing apparently.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Hodor*:

 

There's nothing wrong with the plugin. Your server is broken.

 

I've been busy and haven't had a chance to look into your problem directly.

 

Don't be a jerk.

Tell that to my grandmother that your plugin works fine!
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by ColColonCleaner*:

 

Tell that to my grandmother that your plugin works fine!

I'll inform the 2000 servers running this plugin that it does indeed function correctly.

 

We provide help when we can, devote our time to providing this community with amazing tools to make admin's jobs easier, FOR FREE. And yet here you are, insulting a developer directly for not acting on your petty issue fast enough? Give him a donation to speed up the process? I've released full featured updates for specific people simply because they helped in some way, it's not hard to get results from people simply by not being a dick about it.

 

These developers have lives, it's a hobby for us, not a job. And, on top of it, this isn't even the first thread you've done this in. Whether you're an immature adult, or a pre-teen, leave, get your unappreciative ass off these forums.

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by Hodor*:

 

I'll inform the 2000 servers running this plugin that it does indeed function correctly.

 

We provide help when we can, devote our time to providing this community with amazing tools to make admin's jobs easier, FOR FREE. And yet here you are, insulting a developer directly for not acting on your petty issue fast enough? Give him a donation to speed up the process? I've released full featured updates for specific people simply because they helped in some way, it's not hard to get results from people simply by not being a dick about it.

 

These developers have lives, it's a hobby for us, not a job. And, on top of it, this isn't even the first thread you've done this in. Whether you're an immature adult, or a pre-teen, leave, get your unappreciative ass off these forums.

Yeah yeah yeah yeah
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by EBassie*:

 

Yeah yeah yeah yeah

Hodor, I've warned you in the past about your behaviour. You now earned yourself a nice time-out.

See you in a month.

 

 

 

 

Yeah Yeah Yeah Yeah

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by powerbits*:

 

is there someway to change the map config offline and upload it to the procon server? Because changing it online takes so much time for me

* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by falcontx*:

 

is there someway to change the map config offline and upload it to the procon server? Because changing it online takes so much time for me

Theoretically, yet, but it's not trivial. You can edit the server's config file directly. It's the file in the Configs folder named after your server's IP address/port (e.g. 192.128.5.5_9999.cfg).
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by kcuestag*:

 

Is there any chance that R42 server patch has changed the way or timing of tickets sent on round end?

 

I have the following Config:

 

0-35 Players: Domination Locker 300% (900 Tickets) Preset:

 

Code:

# Custom Preset: Normal - 300% Tickets 200% Time Limit
vars.preset Classic
vars.friendlyFire true
vars.roundTimeLimit 200
vars.gameModeCounter 300
36-64 Players: Conquest Large 100% (800 Tickets) Preset:

 

Code:

# Custom Preset: Classic - 100% Tickets 100% Time Limit
vars.roundTimeLimit 100
vars.gameModeCounter 100
vars.preset Classic
vars.friendlyFire true
I noticed that when it changes to conquest, it does 2400 tickets, instead of 800, I don't know why... It was working just fine, maybe it happened once in a week before the patch, but now it happens a few times daily!
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by falcontx*:

 

Is there any chance that R42 server patch has changed the way or timing of tickets sent on round end?

 

I have the following Config:

 

0-35 Players: Domination Locker 300% (900 Tickets) Preset:

 

Code:

# Custom Preset: Normal - 300% Tickets 200% Time Limit
vars.preset Classic
vars.friendlyFire true
vars.roundTimeLimit 200
vars.gameModeCounter 300
36-64 Players: Conquest Large 100% (800 Tickets) Preset:

 

Code:

# Custom Preset: Classic - 100% Tickets 100% Time Limit
vars.roundTimeLimit 100
vars.gameModeCounter 100
vars.preset Classic
vars.friendlyFire true
I noticed that when it changes to conquest, it does 2400 tickets, instead of 800, I don't know why... It was working just fine, maybe it happened once in a week before the patch, but now it happens a few times daily!
Who knows. I wish they'd stop changing things. I plan to release an update that will allow you to adjust the timing without editing the code. I just haven't had a chance, yet.
* Restored post. It could be that the author is no longer active.
Link to post

Originally Posted by GaWebDev*:

 

Is there any chance that R42 server patch has changed the way or timing of tickets sent on round end?

 

I have the following Config:

 

0-35 Players: Domination Locker 300% (900 Tickets) Preset:

 

Code:

# Custom Preset: Normal - 300% Tickets 200% Time Limit
vars.preset Classic
vars.friendlyFire true
vars.roundTimeLimit 200
vars.gameModeCounter 300
36-64 Players: Conquest Large 100% (800 Tickets) Preset:

 

Code:

# Custom Preset: Classic - 100% Tickets 100% Time Limit
vars.roundTimeLimit 100
vars.gameModeCounter 100
vars.preset Classic
vars.friendlyFire true
I noticed that when it changes to conquest, it does 2400 tickets, instead of 800, I don't know why... It was working just fine, maybe it happened once in a week before the patch, but now it happens a few times daily!
Hey kcuestag. Did you get this issue resolved or at least a work-around implemented? Looking seriously at using on our classic mode BF4 server to alternate modes using DOM for like less than 15 and CNQ Large +15. Did not want to load it if it has issues throwing those tickets up like that though.

 

Thanks!

* Restored post. It could be that the author is no longer active.
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Game Server Hosting:

      We're happy to announce that EZRCON will branch out into the game server provider scene. This is a big step for us so please having patience if something doesn't go right in this area. Now, what makes us different compared to other providers? Well, we're going with the idea of having a scaleable server hosting and providing more control in how you set up your server. For example, in Minecraft, you have the ability to control how many CPU cores you wish your server to have access to, how much RAM you want to use, how much disk space you want to use. This type of control can't be offered in a single service package so you're able to configure a custom package the way you want it.

      You can see all the available games here. Currently, we have the following games available.

      Valheim (From $1.50 USD)


      Rust (From $3.20 USD)


      Minecraft (Basic) (From $4.00 USD)


      Call of Duty 4X (From $7.00 USD)


      OpenTTD (From $4.00 USD)


      Squad (From $9.00 USD)


      Insurgency: Sandstorm (From $6.40 USD)


      Changes to US-East:

      Starting in January 2022, we will be moving to a different provider that has better support, better infrastructure, and better connectivity. We've noticed that the connection/routes to this location are not ideal and it's been hard getting support to correct this. Our contract for our two servers ends in March/April respectively. If you currently have servers in this location you will be migrated over to the new provider. We'll have more details when the time comes closer to January. The new location for this change will be based out of Atlanta, GA. If you have any questions/concerns please open a ticket and we'll do our best to answer them.
      • 1 reply
    • Hello All,

      I wanted to give an update to how EZRCON is doing. As of today we have 56 active customers using the services offered. I'm glad its doing so well and it hasn't been 1 year yet. To those that have services with EZRCON, I hope the service is doing well and if not please let us know so that we can improve it where possible. We've done quite a few changes behind the scenes to improve the performance hopefully. 

      We'll be launching a new location for hosting procon layers in either Los Angeles, USA or Chicago, IL. Still being decided on where the placement should be but these two locations are not set in stone yet. We would like to get feedback on where we should have a new location for hosting the Procon Layers, which you can do by replying to this topic. A poll will be created where people can vote on which location they would like to see.

      We're also looking for some suggestions on what else you would like to see for hosting provider options. So please let us know your thoughts on this matter.
      • 4 replies
    • Hi All,

      So seeing as Venice Unleased is released, I'm looking into if I should offer game hosting for it. I would like some feedback on this subject.

      VU - Experience Battlefield 3 like never before! (veniceunleashed.net)
      • 3 replies
    • So as the topic title says, should EZRCON offer general web hosting services?
      • 1 reply
    • Added ability to disable the new API check for player country info


      Updated GeoIP database file


      Removed usage sending stats


      Added EZRCON ad banner



      If you are upgrading then you may need to add these two lines to your existing installation in the file procon.cfg. To enable these options just change False to True.

      procon.private.options.UseGeoIpFileOnly False
      procon.private.options.BlockRssFeedNews False



       
      • 2 replies
×
×
  • Create New...

Important Information

Please review our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.